USING THE LAYERS PANEL


LandVision™ Help > Documentation > Using The Layers

From the Layers Panel you can view and modify all your layers by accessing many of the powerful tools in LandVision, such as Thematic Mapper.

Layers Panel Overview


  • To open the Layers Panel, click the Layers Panel icon Layers Panel Icon from the Main Toolbar.

  • To make a layer visible, click the box Layers checkbox Icon to the left of the layer name.

  • To style a layer, see the Thematic Mapper documentation.
Layers Panel

Groups Overview


  • By default, Layers are located within thematic Groups.

  • The Layers within a group will show up in the same order on the mapping interface as they do within the Layers Panel. The Layers at the top will overlay the layers that are lower in the Group.

  • To move a layer to another position within a group, drag and drop it in the desired location.

  • To move a layer to a different group, click on the Layer Options icon Layers Options Icon and select Layer Properties from the menu. Next, select Group Name that it should be moved to. You can create a new Group name by selecting New.
Layer Group

Layer Group

Layer Tooltips


  • Tooltips enable information gathering at a glance by quickly hovering over a parcel or other active feature. Layer tooltips can be activated on most layers by clicking the tooltip toggle Tooltips and layers on the layer. You can also edit the information that appears in the tooltip.

  • Read more about using and editing the Tooltips in the documentation.

Tooltip Example

Tooltip example

Adding more Layers to the Layers Panel


  1. Click the More Layers button Gov Clarity Legend Button More Layers at the bottom of the Layers Panel. The Browse Layers window appears.

    Note: The Browse Layers window enables you to add, remove, and delete layers from the Layers Panel. This is also where you can load your data into LandVision.


  2. In the Available list, click the layer you would like to add to the Layers Panel.

    Tip: You can add more than one Layer to the Layers Panel at once by holding down the Ctrl key on your keyboard and clicking on each of the desired layers.


  3. Click the right arrow Gov Clarity Browser Window Right Arrow to move your selected layer(s) to the Active list.

    Tip: To remove any layer from the Active list, select it and then click the left arrow Gov Clarity Browser Window Left Arrow.


  4. Click the OK button at the bottom of the Browse Layers window. LandVision™ adds your layer(s) to the Layers Panel.
Layers Panel

Gov Clarity Add Layers

Removing and Deleting Layers


Removing a layer:

  1. Click the Options icon Layers Options Icon on the layer you would like to remove. The Options menu appears.

  2. Click Remove Layer on the menu. The layer is removed from the Layers Panel.

    Alert: After you remove a layer from the Layers Panel it is not deleted. See instructions below to delete a layer.


Deleting a layer:
  1. Click the More Layers button Gov Clarity Legend Button More Layers at the bottom of the Layers Panel. The Browse Layers window appears.

  2. In the Available list or the Active list, click the layer you would like to delete.

  3. Click the Delete Layer button Gov Clarity Button Delete Layer . A confirmation box appears.

  4. Click OK in the confirmation box to delete the layer.
Remove Layer Option

Layers Panel

Gov Clarity Delete Layer

Layer Options Menu




This section describes these options on the Layer Options menu:

  • Create Label
  • Clear Label
  • Layer Properties
  • Save As...
  • Save a Copy As...
  • Zoom to Bounds

Note: For information about Remove Layer, see the section above: Removing and Deleting Layers.

See Related Documents for information about these options:
  • Create New Filter: Create Custom Search Filters
  • Edit Style: Thematic Mapper
  • Extract: Extract Layer to Shapefile
Layer Options Menu

Save Copy As Option


Create Label

The Create Label option creates a label layer. A label layer displays a label for every feature on the map associated with a selected field in your database.

Tip: It is the best practice to review the values of the fields in your database before creating a label layer.

  1. Click the Options icon Layers Options Icon on the layer you would like to label. The Options menu appears.
  2. Click Create Label on the menu.
  3. Select a Field in your database from the drop-down list that contains the values you would like to appear as labels. In the example to the right, we selected the Parcels layer and selected a field of APN.
  4. Click the OK button. The map displays the labels, and the Layers Panel displays the label layer with the name of your selected Field. In the example to the right, we now have the APN label over each parcel.
    Tip: It is the best practice to keep a label layer and its corresponding data layer together in the Layers Panel.
  5. To edit the style of the labels on the map, such as changing the fill or line color, select Edit Style from the Options icon Layers Options Icon next to the label layer.
Create Label Option

Example of Parcel Label Layer for APN


Clear Layer

The Clear Layer option permanently deletes all data from the layer.

Warning: Since all data will be permanently deleted, use with caution. This is not limited to markup or drawings. If you clear layer, the layer will be completely empty with no data.

  1. Click the Options icon on a layer to view, enter, or edit its properties. The Options menu appears.
  2. Select Clear Layer
  3. A dialogue appears stating that you are permanently deleting all data and content within that layer and it cannot be recovered
  4. Select yes to clear all data on that layer.
Clear Label Option
Layer Properties
  1. Click the Options icon Layers Options Icon on a layer to view, enter, or edit its properties. The Options menu appears.
  2. Click Layer Properties on the menu. The Layer Settings window appears.
  3. Select your desired options in the Layer Settings window. Your selections are not enabled until you click OK at the bottom of the window.
  • Title: Edit the layer name here if desired.
  • Abstract: The best practice is to enter a description of the layer data.
  • Attribution: The best practice is to enter details such as who loaded the layer data, the date the data was loaded, and the source of the data.
  • Group Name: Groups conveniently bring together related layers, such as the Property Data Group. There are three options for Group Name:
    • Select an existing Group Name from the drop-down list. Your selected layer moves to the Group.
    • Select New from the drop-down list to create a new Group for your selected layer. The Create New Group box appears. Enter a new Group Name and click OK.
      The Layers Panel displays a new green group header with your new Group Name. Your selected layer is listed under the group header.
    • Select None from the drop-down list to remove your selected layer from its Group. The Layers Panel displays the layer without a Group.


Layer Properties Options

Layer Properties Settings

Gov Clarity Create New Group Box
  • Min / Max Zoom Level: The Zoom Level range is 1 to 21. The best practice is to set the Max Zoom Level to 21 (zoomed in all the way). It allows you to view the layer at the greatest detail (the parcel level). The Min Zoom Level is 1 (zoomed out to the furthest extent from the map surface).
    The Use Current option sets the current map extent as the zoom level. Select Use Current for the Min or Max Zoom Level by clicking the appropriate check box. The zoom level in the drop-down box is grayed out.

    Note: If you zoom out of the map past your selected Min Zoom Level:
    • The layer will become grayed out until you are once more within your minimum zoom range. (In the example to the right, the top 3 layers are greyed out)
    • The base map is in view, but the features of your layer are not in view. This would occur, for example, if the Min Zoom Level was set to 18, and you zoomed out to the County (level 10 or 11). To view the information, you would need to zoom in closer.







Layer Out Zoom Range
  • Min / Max Longitude and Latitude: Instead of entering map coordinates, the best practice is to select Use Current Map View by clicking the check box. This option sets specific bounds in which your layer is visible. For example, you might use this option to set bounds for the display of a watersheds layer to your City instead of the whole state of California. It would aid in viewing the layer and speed up the display of the layer.
  • Legend Image: Use this option to place an image on any layer listed in the Layers Panel. This enables quick understanding of the layer. For example, you might place an image of a bike on a bike path layer. The image is displayed only on the layer listed in the Layers Panel.
    • Uncheck Auto-Generate to enable your image upload. Auto-Generate displays a default image for a layer if there is one.
    • Click in the Legend Image field to enter the path to an image file.
Save As...

Use this option to save a layer to a different folder. For example, you could save a layer in your User folder to your Group_Folder, such as the Public Works Group. The people in your group would then be able to access your layer.

Note: You must have the appropriate account permission to use this option.

Tip: If this option is not enabled, contact your Account Administrator.
  1. Click the Options icon Layers Options Icon on a layer that you would like to save to a different folder. The Options menu appears.
  2. Click Save As... on the menu. The Save Layer As... window appears.
  3. Select the folder to save your layer from the Folder drop-down list.
  4. Click the Save button.
Save As Option

Gov Clarity Save Layer As Box


Save a Copy As...

This is an Administrator feature.

Zoom to Bounds
  1. Click the Options icon Layers Options Icon on a layer to zoom to its bounds. The Options menu appears.
  2. Click Zoom to Bounds on the menu. The map screen zooms to the bounds of the features on the layer.

    Note: The Min / Max Zoom Level settings may affect the display of layer features. See Min / Max Zoom Level above for details.
Save Copy As Option

View in Time Icons




Use the View in Time option Gov Clarity Layer Icon Clock to view your selected layer at an earlier version. This is very useful to understand the changes that may have been made to the layer.

  1. Click the View in Time icon Gov Clarity Layer Icon Clock on your desired layer. The View in Time box appears.
  2. Click in the Time field. A drop-down box opens with a calendar and sliders to set the time.
  3. Select your desired date and time to view your layer:
    • To select a month/year, click the left or right arrows in the calendar heading.
    • To select a day, click on it. Note: If you don't select a time, it is set to 12:00:00 AM by default.
    • To select the Hour, Minute, or Second, use the appropriate slider.
    • To reset the Time field to the current date and time, click the Now button.
    • To clear the Time field, click the Clear button in the View in Time box.
  4. Click the Done button when you have set your desired date and time. The drop-down box disappears.
  5. Click OK in the View in Time box to view your layer at the selected date and time.
To return your layer view to the current date and time:
  1. Click the View in Time icon Gov Clarity Layer Icon Clock on your layer. The View in Time box appears.
  2. Click in the Time field. A drop-down box opens with a calendar and sliders to set the time.
  3. Click the Now button.
  4. Click the Done button. The drop-down box disappears.
  5. Click Ok in the View in Time box.




View In Time Option

View in Time Window

Setting up Map Views


Creating Map Views enables you to consistently return to a map view with only the map layers, styles, and settings relevant to a specific project. For example, if you're working on a project concerning Points of Interest, you might create a Map View with Points of Interest turned on.

You have many options for editing the look and feel of the data that is displayed in each Map View. Each individual Map View can have its own unique set of layers, styles, order, controls, and features. When you save a Map View it includes all your current settings in LandVision™. There is no limit on the number of Map Views that you can create.

The following example workflow is intended to increase your understanding of Map Views.

  1. Click the Open button at the bottom of the Layers Panel. The Open Map Views window appears.

    Note: Home is the default Map View set up by your Administrator. It is the best practice not to overwrite the Home Map View.
  2. Select Production from the Folder drop-down list.
  3. Select Home in the Available list.
  4. Click OK. This enables access to the list of layers that are currently displayed in the Home Map View. You access these layers later in this workflow.
  5. Click the Save button at the bottom of the Layers Panel. The Save As... box appears.
  6. Perform the following in the Save As... box:
    • Folder: Select the User folder.
    • Name: Enter Parks as the name to save this Map View. (Let's assume for this example we are working on creating a Points of Interest Map View).

      Tip: Saving the Map View to your USER folder allows you to make edits and changes to the Map View and get any final approvals before sharing this information to all users in the Production folder.


  7. Click the More Layers button at the bottom of the Layers Panel to add any desired layers now in the Production folder to the Layers Panel. The Browse Layers window appears. See the section above, Adding more Layers to the Layers Panel, for instructions.


  8. With all layers now added to the Points of Interest Map View, you can begin grouping the layers and setting the view status. See Layer Properties above for instructions.

    Tip: LandVision™ allows you to define whether a layer is automatically On or Off when the Map View is loaded, as well as whether the layer is identified.

    Tip: LandVision™ utilizes Autosave functionality. When you exit, and then log back into the application, it zooms to the last map view, including the same Map View.


  9. At this point in the workflow:
    • You could Share this Map View with another user for approval.
      OR..
    • You could Save this Map View to the Production Folder to provide access to anyone in the agency.


Here's how you would Share the Map View:
  1. Save the Map View to the Share folder.
  2. Instruct the other user to click the Open button at the bottom of the Layers Panel, and then navigate to the Share folder where the file you saved is located.
  3. The other user can make additional changes to the Map View and either overwrite the changes or save them with a different name.
Once the Map View is approved, it can to be saved to the Production folder for anyone in the agency to access it.

Here's how you would save the Map View directly to the Production folder:
  • Click the Save button at the bottom of the Layers Panel and select the Production folder.
  • Name the Map View and click Save.

    Note: There are two significant differences between the Share and Production folder.
    1. Only Administrators can add Map Views and Layers to the Production folder
    2. The Share folder allows all users to change and delete data. The production folder only allows users the ability to access and read the data.
Now anyone in the agency has access to this new Map View.
Legend Open Map View Window

Save Map View Box

Change Settings


The Change Settings button at the bottom of the Layers Panel is for Administrators Only.

Warning: Do not use this feature unless you understand folder levels and account permissions in LandVision™.

Related Documents



© Copyright 2018 Digital Map Products About DMP | Contact Us